Nissan X-Trail Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
I am looking for suggestions for why my T30 (2002) diesel is giving me running problems. The best way to describe it, is that when overtaking, or accelerating, it is like I am hitting the rev-limiter. If I keep my foot on the accelerator, then it does clear itself, and is going fine for a few moments, or sometimes it runs okay for 20 mins, with just the odd hiccup.

I have changed the fuel filter, and this cures the problem, but.......I have changed two in 7,000 miles, and the problem has started again. Do I have a fuel tank full of ****, or is there something else behind this problem? The car has done 90K, uses no oil, smokes a little, especially when cold, but runs well. Do I need to take fuel tank off, drain it & clean it? I would appreciate any suggestions. :headbang:
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #3 ·
Colin,
Do you have any suggestions on how to take it off easily? There are four screws on the top, which are a little difficult to access due to the bulkhead. They are only soft crosshead screws, and I don't want to damage them. Can I soak them in WD40 to loosen?
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #4 ·
I have had the EGR valve off, easy really, A bit of WD40 when hot, which means the metal is expanded, and when it cools, the WD40 is where it should be!
Anyway, Valve off, cleaned with brake cleaner, as per the posts on the topic, and it still does not run right. Where do I go from here? :-?
 

·
Registered
Joined
·
1,718 Posts
Hi Daleslad
I know diddly squat 'bout diesels but could the problem be an ignition related thing? I know you have glow plugs rather than sparkies but is there a chance there is a problem in this area?
You can laugh if you like - as said, I know nothing about diesels but I'd be looking in this area on a petrol car.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #6 ·
The glow plugs were changed about three months ago, or approx 5K miles.

I know what you mean re petrol vs. diesel, it took a while for me to fully convert, but over the years, the torque of the diesel is so much better, not needing to rev so high etc, and of course, the fuel economy. I did go back to a petrol with a subaru, but now back with a X-trail.
 

·
Registered
Joined
·
1,718 Posts
daleslad said:
The glow plugs were changed about three months ago, or approx 5K miles.

I know what you mean re petrol vs. diesel, it took a while for me to fully convert, but over the years, the torque of the diesel is so much better, not needing to rev so high etc, and of course, the fuel economy. I did go back to a petrol with a subaru, but now back with a X-trail.
Don't worry - I wasn't trying to convert you - fully agree about the torque benefit - what? I'm singing the praises of a diesel :lol:
Have you checked the injectors?
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #9 ·
When I got the car, because it was smoking, I put a whole load of those injector cleaners through the system, so they should be clean.
The running was a bit better this morning, but is now kangarooing as described in other threads, but not all the time. I think maybe the EGR was a little stuck, and is now working itself free. I probably need to give it a bit of a longer run and see if it improves.

You won't convert me from a diesel, but I do miss having 250bhp! A bit of a change to 114, but nearly 40mpg is better than 16ish.
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top