Nissan X-Trail Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
47 Posts
Discussion Starter · #1 ·
Hi there.

Driving back from Cornwall on the motorway today something happened to my XT.
When under load at about 2650 rpm the engine stops pulling as if I have hit a rev limiter, no power but just remains at 2650 RPM.
I have tried it in 4th 5th and 6th Gears, with and without the Cruise, all seem to make no difference, it does it intermittently when you hit the 2650 rpm.

Incidentaly when accelerating hard this week I thought I had hit the 5K rev limiter (If it has one), a couple of times whilst accelerating in 2nd and 3rd, but looking back it may be the same problem.

When I stopped the engine, the problem did not really occur until I had driven a few miles again. (No oil leaks or problems visible under the hood and no smoke from the exhaust)

I had a new Intercooler fitted 1500 miles ago due to leaks and massive oil over the engine casing leaking from the IC, but this is something new.

Could it be electronic or has the Turbo got a wastegate where it dumps pressure if it builds up too much????

I have booked it into West Way in Kidlington (Oxon) for Thursday next week, but any ideas?

Cheers in advance.
 

·
Registered
Joined
·
1,452 Posts
Sorry, I'm not clued up on Diesels so cant help but have a free bump anyway! :grin:

I have a friend with a Diesel approaching 60k and he's having the same problem so any info would be great. Seems to only affect it in 5th gear. Is there not a common turbo actuator fault with these cars once they get to a certain mileage or have I been misinformed?

Thanks in advance peeps :ugeek:
 

·
Registered
Joined
·
47 Posts
Discussion Starter · #3 ·
Thanks for the bump.

Well, I took it to WestWay Nissan in Kidlington Oxon, who were exceptionally helpful, they did however annoy me slightly as the loan car they gave me was a 2010 X-Trail Tekna, with leather seats and all the bells and whistles...............didn't even have to put diesel in it when I returned it. It was a lovely car and if I had £27K I wouldn't hesitate to buy a new one tomorrow.

Anyway, they phoned me up as the tech was filling in the job sheet to say it was ready. (After 3 hours)
When I got back to the dealership, after a scenic route around Oxon....ahem....in the new XT.........and I even tried to put a fiver of diesel in it coz I felt guilty....but couldn't as I couldn't find the fuel filler flap opening switch (Doh), I apologised for not topping up the gas, they said no problem at all.

The tech had checked the Turbo vacumn pipes, found all OK, took it for a test drive, which confirmed what I had said, so he opened up the airbox to check the filter (Which had been replaced on the service at Stourbridge when I purchased it) and found...........a new filter 90% covered and blocked by an old oily rag! (on the outside side of the filter fortunately). He was to say the least gobsmacked. :headbang:

As I drove home all seemed fine, I have yet to load the engine really hard up fish hill nearby (Steep steep curving hill near Broadway tower) but initial reports are good. :thumbs:

Maybe now I'll get a drop in fuel consumption from 30 - 32mpg to about 38 as I expected it to do....

So there we are....a letter to the Stourbridge Westway is maybe in order, but they have been kind in the past, skimming the discs when I complained of high speed brake judder....which cured the problem, so I may just drop the complaint and get it serviced in Oxford instead. :thumbs:

Plus the service receptionist at Kidlington (Jem) is exceptionally helpful and pretty to boot :eek:fftopic:
 

·
Registered
Joined
·
47 Posts
Discussion Starter · #5 ·
UPDATE

:biggrin:

I have just taken my X-Trail in for the fourth time to let the Nissan GB engineer look at it after they told me the turbo will need replacing after all due to build up of carbon on the vanes......cost to me (before I told them I had a warranty from purchase in August :gathering: ) £1250.00.....ouch!

Anyway Nissan have agreed as a good will gesture to fund some of the cost, the remainder will be picked up by the Nissan warranty company....excelent news........they need to replace two (One is leaking but they must change in pairs) leaking rear shockers too....result. :thumbs:

So next week it goes in for a new Turbo......

Apparently they are a modded variety.....can anyone confirm this?

Also strangely they do not change the oil, so I am going to put some new Comma fully synth (as recommended here) and a filter on as soon as it gets home as it's done 7K since its last oil change and I will be doing half way oil services to preserve the engine....
 

·
Registered
Joined
·
47 Posts
Discussion Starter · #6 ·
Well.......................

A few weeks on, and the problem seems to have gone away - no cutting out at all so far so it appears that the turbo replacement was required.

So far in 9000 miles since I got this car (under warranty) I have had:

A New Intercooler
Both Front Disks skimmed due to judder
A New Turbo
A New Offside Rear Shock absorber assembly
Fixed Rear heater element (Earth Fault)
A Rag removed from the air filter box
4 New plastic pins to keep the rubber trim on on the back doors.

Now only last week the alloy heat sheild above the back box fell off and will need replacing as the thing wore through and has left 10p sized holes where the bolts go.

AAARRRRRRRGGGGGHHHHHHH,

(Still at least all work done under warranty)
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top