Nissan X-Trail Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter · #1 ·
evening all

i have a problem with the Engine management light coming on which when cancelled stays off for around a week or so before coming back on, diagnosing the fault the "accelerator way" shows the fault to be 0138 indicating a rear lambda sensor, does this sound as though the sensor is on its way out and getting ready for replacement, X trail is an 04 with 58K on clock,both front and rear sensors have 4 wires of the same colours, 2 white one black and one grey, two different prices from nissan quoted at £140 and £174 each, universal ones available under £20 which i am considering giving a go if problem persists...

any body experienced the same or similar...theory has it sensors should be changed like spark plugs.....

cheers Keith
 

·
Registered
Joined
·
6 Posts
Hi

Lambda sensors only last about 50K anyway - but usually only get changed when the warning light comes on. The price difference is because they both serve different functions - the front monitors the emission Nox gases and tells the ECU to trim the fuel air ratio, the rear sensor monitors the efficiency of the catalytric converter.

Do NOT use universal sensors - the signal generated is only between 0 and 1 volt so any extra resistance in the cabling connectors can cause problems. Try a local motor factor for an aftermarket sensor bosch/ntk makes are popular - much cheaper than the dealer prices

Good luck

PS you may to reset the ECU to clear the fault code after you have fitted the new sensor
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top