Nissan X-Trail Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter · #1 ·
Only had our Xtrail just over a month!
it is a 07 model
last week we were caravaning and run out of fuel on the A1M we did suspect that there was a problem with the fuel guage but we at least expected the warning light to come on!
Nothing!!!
The problem when we ran out of fuel the fuel gauge was still showing almost three quarters of a tank, we had completely filled the tank prior to setting off and had done 292 when we ran miles so we did suspect there was a problem .

Have taken the sender out of the tank nothing! if you diconnect the wires the fuel warning light will come on and the tank will show empty!

There are two sensor units according to the garage one either side! when you take both of these out and hold then equally then the warning light comes on and the gauge works.

You put them back in the tank and they dont work again!

Any ideas anyone???

It doesn't sound like the sensors are not working does it? They cost £166 each by the way plus vat!

thanks for any replies
 

·
Registered
Joined
·
1,718 Posts
Hi annadoodle

I'm just trying to get my head around this! If you disconnect the wires the light comes on and tank shows empty? When you take them both out and hold them level then the gauge works - showing empty? When you put them back in and nothing happens then it sounds like a connection fault rather than the sender units as if these were broken then they wouldn't work either in or out of the tank. It could possibly be a bad earth connection? You need your garage to check the wiring first I would say. Is this the first time you have towed (or more importantly, is this the first time you have plugged in to your tow bar connection - if so it may be worth having them check this out also)
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #4 ·
Thanks Vardy!
It is the same whether we are towing or not!

Only had the vehicle a month!

to extend!

The fuel gauge is not working, showing almost a full tank when we ran out of diesel, the fuel warning light never came on.

Have taken both fuel sender untils out of the tank - when held at the same level they work

BUT! when you put them back in the tank they dont!!! strange!

Could this be due to the fuel not leveling correctly i'e more in one side then the other???

If you disconnet both sender units the fuel guage goes to empty and the waring light comes on

thanks again
 

·
Registered
Joined
·
1,718 Posts
Annadoodle.
Best advice is seeing that you've only had the car for a month - take it back and get them to sort it out for you - you should have a minimum 3 month warranty with the car (assuming you bought it from a dealer and not privately?)
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top