Nissan X-Trail Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
I have a 2002 X-trail Sport 2.2di. Ive been having trouble starting my X-trail in the morning. I left my xtrail on a hill and was fit to start her ok after a small run down the hill in the morning. I have changed the glow plugs and my problem is not as bad but it's still not fully repaired. Can anyone tell me the location of the relay for the glow plugs?? Or has anyone any other ideas on what might be causing my problem. It's only in the morning once she warms up there are no issues with starting or running my x trail for the rest of the day.
 

·
Administrator
Joined
·
2,758 Posts
Aidanmc said:
Umbongo, thanks for your help!
No problem.
The relay for the Glow plugs is part No:25230WD000 and isn't a cheap part like most X-Trail parts 60-70 notes could be more from dealer. :frown:
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #5 ·
I got a second hand glow plug from a scrapyard? 10 squid. I tested it with a multimeter and it's fine. Hopefully it will do the trick.
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #6 ·
Lads,

When I got in at the relay I discovered that the relay wasnt the problem. It was the green plug that plugs into the relay. It was all corroded in the inside. I will get new plug from the same scrap yard but is this a big job to wire up?? Is it time to take my X trail to a professional??
 

·
Administrator
Joined
·
2,758 Posts
Aidanmc said:
Lads,

When I got in at the relay I discovered that the relay wasnt the problem. It was the green plug that plugs into the relay. It was all corroded in the inside.
Are you sure that you have the correct relay plug located?.....................as it sounds to me that you've got the wrong one.I took a look at mine and it is a black plug and black relay n/s engine bay.I've marked out the location for you in red in diagrams and there is some info for a few tests.

 

Attachments

1 - 7 of 7 Posts
Top