Nissan X-Trail Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Any help on this would be great, handbrake light started flickering when driving and now on solid.
I have changed pads checked fluid and ruled out a handbrake lever fault by disconnecting the ECU( had to replace the heater fan) and handbrake light worked perfectly until I hit the brake paddle.
Where next, I will disconnect the level sensor tomorrow ( waiting on some electrical contact cleaner) to clean the terminals.
If this doesn't sort any ideas on what else to try.
The forum has helped me out so much and any help on this would be great.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #2 ·
Follow up cleaned brake fluid sensor connector handbrake light still on, are there any other sensors on that circuit ??
Any pointers would be great.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #4 ·
Unfortunately not brake lights working normally, might have to bite the bullet and replace the master cylinder to rule out a faulty level sensor.
Thanks Leafy
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #6 ·
My first thought, but after unplugging the ECU the handbrake switch worked and the light went out..
It only came back on when I hit the brake pedal.
I have not found anyone with a similar problem.
Are there any other sensors that anyone has come across on this circuit that may be at fault before I start throwing money at it?.
Thanks for the info so far.
 

·
Registered
Joined
·
2,983 Posts
I do not think that the ecu has to do with the handbrake switch.
Body control module and abs controller.
Go to a garage where they have a proper scan tool, Autel or Launch.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #8 ·
OK will give it a go should have access to a LAUNCH system.
Thanks AHTO42
 
1 - 8 of 8 Posts
Top