Nissan X-Trail Forum banner
1 - 7 of 7 Posts
G

·
Discussion Starter · #1 ·
Hi Guys, I am in need of some expert advice from the mechanical minded or previous problems that some Exy owners may have had and resolved. It will probably ended up a long winded post as I want to get all of the details out of what when how and why if I can so please bear with me :roll:

I bought my first Exy about 4 weeks ago, it is a 2002 2.0 Petrol SE+ with 82,000 on it. 1 previous owner with full Nissan history. When I bought the car it started fine when I was looking around it etc etc, but the next day I couldn't get it started, it would just turn over abit but not fire up then the battery would die. Once I boosted the battery it started with abit of a judder and rough running then be ok. If I went back to the car in 10 mins or 5 hours it would start up again no problems. leave it overnight or in very cold or wet conditions then I would have problems again.

It was due a oil service only, but decided to do the Oil, Air & Sparks aswell (just to be sure). On removal of the spark plugs the 2 left ones had a petrol smell to it. My guy said it could be a few things, Lambda sensor is caput or the injectors.......... I have put in some Injector cleaner to see if it improves anything this afternoon.

The main problem and worry i have now is that this morning, she started up fine even though it was a very cold morning, I drove about 5 miles down the road and going about 70mpg on the dual carriageway. Suddently the rev counter dropped and stayed dropped, loss quite abit of power even though it still drove. I managed to get to my destination without conking out, where upon arrival the rev counter came back and power. I got out to look under the hood to see if I could see or smell anything. I could smell a burn kind of an electrical burn mostly coming from the 2 from left spark plug area.

She drove back from that place to home fine. Took it too work tonight and she was fine. Left it 10 hours at work and started ok. Now I am thinking could this be a knackered coil pack? I am hoping that the injectors won't need replacing as I would have to remortgage probably :( The coil pack would that have this kind of bad starts of engine power loss?

Also on a different note, i am getting about 65miles to quarter of a tank, seems kind of rich to me (my car before was a diesel though), could this be down to the petrol around the sparks?

I need help, but as most of us money is tight and I cannot really afford to get it into a garage to give it a full going over :(

Thanks all :bow:
 
G

·
Discussion Starter · #3 ·
Will defo take a look at that as that will hopefully sort out my overfuelling prob.

Thank :biggrin:
 

·
Registered
Joined
·
28 Posts
Hmmm I would have thought with the problems you have been having that the engine management light would be having a ****y by now ??

When you switch the ignition on for the first time does the engine managment light glow up ?

Unscrupulous people do take the bulb out of these if its flashing errors.
 

·
Registered
Joined
·
16 Posts
this problem has already been mentioned a couple of times on this forum. myself and one other have mentioned it we also have 2.0 se+. revs have never dropped off but starting problems yes. i find that if u turn the ignition on and wait for the dash lights to go off then the turn the engine over it will solve your problems. it is to do with so many electrical components trying to start at the same time on the se+. also i get less than 65 miles to a quarter tank. you driving a heavy car with a 2 ltr petrol engine in. i work for nissan and even the brand new cars top the range have problems starting after been left in a cold car park for a few nights.
 
G

·
Discussion Starter · #7 ·
Thanks for the reply. I always let the lights go out on the dash before I start it, but like this morning with the frost it had to be boosted. The last few days with it being a mild morning it started no problems. Doesn't seem to be a massive umphh! when it fires up mind you. Just wondering if this could be the coil pack? :confused:
 
1 - 7 of 7 Posts
Top