Nissan X-Trail Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
HI all,

I found the forum while searching for answers to problems with our new to us 04 plate DCi Sport.

Having loved our Tino we though we would go for something out of the same stable for a heavier towcar for the caravan we are planning to buy. Having decided on an X Trail we were having difficulty getting to one to see it before it was snapped up.

I found one in Dundee and as I was passing there for work looked at it and paid a deposit to hold it until my wife could see it.
The car was filthy but not damaged and I new it would clean up well. I also had a full dealer service history, The injectors had recently been replaced and it looked like it had a new turbo and intercooler.

We both went back at the weekend and test drove it and were happy with it except for the brakes.... the salesman said that Arnold Clark always delivers its promises and he promised the car would be fully serviced, cleaned and the brakes sorted.

We picked it up the following Saturday and the trouble started.

The air con was not working, the brakes were as bad as they were when we test drove it and their idea of a clean was to squirt it with a hose and show it a vacuum cleaner.

Being a Saturday the service department was closed so we left being assured that our local Arnold Clarke in Dumbarton (a Nissan Main Dealer) would look at it and sort all the problems.

We are now eight weeks later and it is still going back.... I hope for one last time.

The faults so far corrected are:
Overfilled with oil... Choked air filter... AC not working... front brake discs corroded and warped... front brake calliper frozen... rear brake discs badly corroded... rear brake slides frozen... front seat belts not retracting... radiator mounts loose.... tracking reset... Boost control solenoid valve replaced.... Wiring harness to boost control valve repaired... Mass air sensor replaced. And all of this with a shinny new MOT with no advisories!

Since replacing the boost control valve there has been little or no boost and I think they have replaced a working valve with a faulty one as the original fault turned out to be in the wiring harness.

The thing that annoys me about all of this is that not once has Arnold Clarke looked for any faults in the car, I take it back and say something is wrong, they agree and fix only that part, I find something else and the same happens, even though they say they have checked the car and nothing is wrong, even with a complete lack of boost from the turbo they say that all X-Trails drive like this (I have too keep the reves above 2500 if it is going to pull itself out of bed and it is even worse with 750Kg of caravan on the back, I have difficulty holding 60mph in 6th gear on a flat motorway). If it wasn't for the great performance, especially when towing, before they changed the boost control valve I would have said the X-Trail was poor in general, cut my losses and go for a different brand.

So only 7 Trips to the garage in 8 weeks and hopefully only one more to go and we will finally be happy with the car, because we do love it..... on 2 long weekends to the lake district three weeks ago we did about 1500 miles of touring.

I would like to thank you for the forum and I have gleaned a lot of good help and information while reading through the posts, and I'm sure I'll be back regularly.

John

PS I managed to get a Nissan Electronic service manual for our Tino and was wondering if anyone knows where I can get one for the X-Trail.

Thank you.
 

·
Registered
Joined
·
1,718 Posts
HI John and welcome to the forum. I bought one of the service cd's a while ago - actually from the seller that Umbongo has just posted the link for - it arrive the following day and is very good - gives loads of info and well worth the money.
Enjoy the forum.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #4 ·
Thanks for the welcome.

The boost valve was changed again today but no improvement.... at least they now acknowledge the problem but have admitted they have no clue as to what it may be... It is going back next wednesday for further investigation which I think means they will keep changing bits until it works :headbang: . At least it is not costing me anything and one day I might get a working car.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top