Nissan X-Trail Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I have a 2008 model, the front and rear washers have stopped working. I want to check the connections at the pumps but I am unsure how to get to them (looks like there burried in the wing). Any advice appreciated.
 

·
Registered
Joined
·
2,124 Posts
Hello Rob1634,

Welcome to the Forum. :biggrin:

Have a read of this tread, Umbongo tells you which fuses to check on the T31 for the washers... :thumbs:
viewtopic.php?f=3&t=2796

I am not aware of a thread for the T31 which details the removal of the fenders to access the washer motors.

However, as a guide this thread covers the procedure for the T30 which may help you with your T31...
Umbongo has attached a pdf showing the washer system and fender removal on the T30.
From my experience, you can just drop the front of the plastic fenders on the T30 to access the washer pumps [and front fog lights]. I would check the pump wiring connections and also the pumps for blockages. :thumbs:
viewtopic.php?f=15&t=4890

I hope this helps, and gives you another option or two - for the washers not working. :thumbs:

Best wishes, John
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Thanks for the info. Checked the fuse, I believe there is only 1 on the t31 model, it was good. Looks like the fender off next, I'll let you know how I get on.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #4 ·
After removing part of the wheel arch trim I managed to bend the front part of the fender out of the way. Ah-ah washer pump revealed :smile: .checked for voltage at pump all ok, gave the pump a bit of a tap, as per previous forum suggestions, tried washers both front and rear working ok. :lol:
Not sure what the problem was but it's cured. What was puzzling only one pump with two pipes from it, not sure how this works.

Once again thanks for the info
 

·
Registered
Joined
·
2,124 Posts
Hello Rob1634,

I am pleased to hear you are sorted, and you managed the access without removing all of the plastic fender. :thumbs:

Your one pump and two pipes must be an update over the T30. I was also aware that some T31 models also have washer jets for the HID headlights via another pump... Possibly one of our T31 colleagues may come up with an explanation about the pump arrangements for future reference. :thumbs:

Another task completed at no cost... :thumbs: Thank you for letting us know your problem is now resolved. :biggrin:

Best wishes, John
 

·
Registered
Joined
·
265 Posts
my old car came with a jammed pump, looks like it was
fairy liquid changed into thick soap,
best fill up with warm water
and see if it was stuck with the soap,
 

·
Registered
Joined
·
1 Posts
Thanks guys my 2002 two washers stopped working. Read the notes below. Looked with torch under off side front wing and there is a gap and inspection hole for looking at the pump. Gave it a light tap. Bingo it is now working. Cheers
 

·
Registered
Joined
·
2,837 Posts
Rob1634 said:
What was puzzling only one pump with two pipes from it, not sure how this works.

Once again thanks for the info
That's common these days. The pump motor can spin either way. When it spins one way, water is forced out of one port. When it spins the other, it comes out of the other one. Dead clever! Saves the cost of a second motor. One does front, the other does rear screen.
 

·
Registered
Joined
·
1 Posts
Thanks guys my 2002 two washers stopped working. Read the notes below. Looked with torch under off side front wing and there is a gap and inspection hole for looking at the pump. Gave it a light tap. Bingo it is now working. Cheers
This worked for me, Fantastic! Thanks for great and easy fix!!
 
1 - 9 of 9 Posts
Top