Nissan X-Trail Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Hi Guys,

I was wondering if anyone with better knowledge with me would be able to help me on how the MAF circuit works?

I was experiencing power loss previously (no turbo) if I stopped and started the car again it would be fine for a wee while and boost away then experience a loss of power again.

I disconnected the MAF as recommended by someone on here and the car goes into default values and boosts again.

I've got Delphi diagnostics and looked into all the readings, the IAT (intake air temperature) part of the MAF seems to be working correctly (usually getting around 14 degrees but temp does go up and down slightly but stays around 14 degrees), I'm not getting any other MAF values, I'm getting Boost pressure so feel the MAP sensor is working correctly. and EGR figures are fluctuating aswel so seems to be working correctly.

I've tried two MAF's one from Dingbro which is a Delphi @ £175 and I tried a cheap ebay one at £30 both seem useless .

If anyone has any ideas or things to try that would be great, as I'm really at a loss now.

Cheers

Doug
 

·
Registered
Joined
·
2 Posts
Hi Guys,

I was wondering if anyone with better knowledge with me would be able to help me on how the MAF circuit works?

I was experiencing power loss previously (no turbo) if I stopped and started the car again it would be fine for a wee while and boost away then experience a loss of power again.

I disconnected the MAF as recommended by someone on here and the car goes into default values and boosts again.

I've got Delphi diagnostics and looked into all the readings, the IAT (intake air temperature) part of the MAF seems to be working correctly (usually getting around 14 degrees but temp does go up and down slightly but stays around 14 degrees), I'm not getting any other MAF values, I'm getting Boost pressure so feel the MAP sensor is working correctly. and EGR figures are fluctuating aswel so seems to be working correctly.

I've tried two MAF's one from Dingbro which is a Delphi @ £175 and I tried a cheap ebay one at £30 both seem useless .

If anyone has any ideas or things to try that would be great, as I'm really at a loss now.

Cheers

Doug
Any update?
 
1 - 3 of 3 Posts
Top