Nissan X-Trail Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
Hi please bear with me I’ll try to explain
2006 2.2dci so I had a new head gasket and timing chain fitted couple months ago however when the mechanic put it back together he didn’t change injector seals and sump filled with diesel since then seals have been changed and injectors tested and they come back fine problem I have is since the sump filled up I have had a big problem with black smoke under load , I’ve checked for boost leaks can’t find any I’ve cleaned maf sensor, turbo does leak oil so is being refurbed but they don’t suspect that, I’ve ran car round the lakes with caravan on back to clear it out but smoke still there car doesn’t smoke at idle just when you put your foot down I also noticed with caravan on it had zero power in 5th/6th gear
 

·
Registered
Nissan X Trail Columbia 2.2 DCi 2006
Joined
·
679 Posts
This might sound fairly obvious, but check your air filter. It might look ok on top, but take it out and check underneath.
 

·
Registered
Nissan X Trail Columbia 2.2 DCi 2006
Joined
·
679 Posts
EGR or inlet manifold blocked? Did the injectors go back in the same cylinders?
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #6 ·
I don’t know if the injectors went back in same as garage sent them off to be tested then refitted with new seals as for oil I’m going to flush it and put on new filter when turbo has been returned
 

·
Registered
Nissan X Trail Columbia 2.2 DCi 2006
Joined
·
679 Posts
Injectors have a compensation code to allow for manufacturing tolerances. These codes are stored in the ECM according to cylinder number. If they are not in their original positions, these codes will need updating.

Is there any sign of an oil leak from the intercooler?
 
1 - 8 of 8 Posts
Top