Nissan X-Trail Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 · (Edited)
X Trail 2009, T31 Got a leak on the fuel primer pump, anybody sourced a replacement or alternative system ? It’s a flipping nuisance pumping up the fuel every morning lol
 

·
Registered
08' T31 Adventurer 2.0dci
Joined
·
725 Posts
Non original Priming bulbs on ebay ,can you install one of those or look for someone dismantling an Xtrail .

Anything like this work at all
 

·
Registered
Joined
·
80 Posts
I purchased one for my T31 from Amaya Trading in Japan (Genuine Japanese Car Part Imports - Amayama) it was a genuine Nissan part at almost half the price of a UK sourced part at £17, 3 years ago incl shipping costs . Took just over 2 weeks to come. Go to Partsouq (https://partsouq.com/en) enter your VIN number or search model, takes you to exploded parts diagrams and, from there, part number and suppliers. Put the part number into Google etc.
The fault on my car exhibited as difficulty starting when it had been parked on a slope overnight. The bulb was found to have a hairline crack in the neck where it fitted into the clip.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #4 ·
I purchased one for my T31 from Amaya Trading in Japan (Genuine Japanese Car Part Imports - Amayama) it was a genuine Nissan part at almost half the price of a UK sourced part at £17, 3 years ago incl shipping costs . Took just over 2 weeks to come. Go to Partsouq (https://partsouq.com/en) enter your VIN number or search model, takes you to exploded parts diagrams and, from there, part number and suppliers. Put the part number into Google etc.
The fault on my car exhibited as difficulty starting when it had been parked on a slope overnight. The bulb was found to have a hairline crack in the neck where it fitted into the clip.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #5 ·
Ok thanks I will have look, there’s a breakers not far as well. Yes the bulb is cracked I covered it in silicone but it didn’t work.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #6 ·

·
Registered
Joined
·
499 Posts
I had a problem with my 2008 T31. It would start, run for a few moments, then cut out. Turned out to be a hairline crack in the primer pump. My local garage got one for me and I fitted it myself, a 10 minute easy job. Problem solved!
 
1 - 11 of 11 Posts
Top