Nissan X-Trail Forum banner
1 - 9 of 9 Posts
G

·
Discussion Starter · #1 ·
hi all,

i have an 06 2.2 dci aventura.
when i try to put my foot down it seems to pull back
and splutter with alot of black smoke from the exhaust.

it seems ok if i feather the throttle and only happens
when i try to accelerate hard.

any ideas anyone or has anyone encountered this problem.

thanks again
 

·
Registered
Joined
·
115 Posts
Mine has l just started doig this, well twice in the last 7 days - one before the snow, mine seems to do it when I have been in very slow 1st and 2nd gear traffic, and then free road ahead so accelerate and then at about 50mph it stutters - I back off and then its ok again....
 
G

·
Discussion Starter · #3 ·
forgot to mention that it bearly goes over 70
without farting / spluttering and pulling back.

has anyone any ideas what this could be?

thanks again :headbang:
 

·
Registered
Joined
·
40 Posts
knackered said:
forgot to mention that it bearly goes over 70
without farting / spluttering and pulling back.

has anyone any ideas what this could be?

thanks again :headbang:
If you use cheap fuel it could be the water trap inside the fuel filter freezing up, or stuck egr! The usual 2!
 

·
Registered
Joined
·
115 Posts
so....how does one go about either empty/replace the water trap thingy or indeed unsticking the egr whatsit...?
Water trap makes sense with the cold temps about at the mo.
Cheers

Robbo
 

·
Registered
Joined
·
40 Posts
Robbo said:
so....how does one go about either empty/replace the water trap thingy or indeed unsticking the egr whatsit...?
Water trap makes sense with the cold temps about at the mo.
Cheers

Robbo
Water trap is on the bottom of the fuel filter on an old style fuel filter and on the side at the bottom on a new style, unscrew to open and press the primer ball a few times with a cup underneath filter to collect water/fuel. If still persists and the filter is the old style (not with pipes part of filter casing!) Take off fuel filter and see if element inside is being sucked out of the outer ring of holes (the output!) If it is or is close, replace filter!

Easiest thing to do with egr is to blank it off at the exhaust manifold first to see if problem goes, then its a bit of a fiddle to remove and clean egr if required!

Egg
 

·
Registered
Joined
·
36 Posts
Our 2.2 SVE has been doing this too. When accelerating at about 70 mph there is a slight hesitatation, almost a misfire, back off the throttle at little then it seems OK again for a while. The temperatures have been quite low so thought it could be a little water in the fuel filter freezing. It will have to warm up again though before I investigate further.....
 

·
Registered
Joined
·
5 Posts
Hi,

I had the same problem with my 2006 DCi at 49,000 miles replaced the fuel filter/water seperator done 10,000 miles since with no problems, I have been led to believe that Nissan only 'check' these filters on services if they look ok and no water comes out the drain they leave them hence they block up fairly easy to change yourself
 
G

·
Discussion Starter · #9 ·
Thanks to the subscribers to this forum I have been able to have the spluttering problem with my 2006 Aventura 53,000 miles cured - by replacing the fuel filter. As I only bought the car in July and have driven it for barely 3,500 miles I felt that the dealer should replace the fuel filter for free but they insisted it was a service item and I had to pay £70.49! However, the car now accelerates, to put it mildly, extremely well
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top