Nissan X-Trail Forum banner
1 - 2 of 2 Posts

Discussion Starter · #1 ·
Cross-posted to 'T30 How-tos'

Hi all,

Just bought a 2006 Aventura - came with 4 keys. 1 key worked perfectly (remote & start), 1 key the remote didnt work but starts car, 2 keys remote opened car but wouldnt start engine (get "WAIT" on Audio display, then after a minute "SECURE" and neither will start the car??).

So I followed the steps to reprogram code (6 turns etc), it reprogrammed the first one correctly, then I stuffed it somehow, so tried again and it wiped all 4 - now none of the 4 work the remote, 2 will still start the engine, other 2 still dont start.

Have tried the 6 turns again, but it refuses to go into reprogramming mode (indicators dont flash at end of 6th turn) (perhaps because I no longer have a working remote to lock/open the car the first time).

Any ideas??? - I will call a Nissan dealer in the morning to see how much they might charge to reset the keys.

I am assuming I stuffed the Remote code which should be easy for them to reset, the 2 keys that wont work with the immobiliser might take a bit more effort...

Discussion Starter · #2 ·

To go into programminng mode,you have to use one of the 2 keys that work with the immobiliser.
You don't need to have a working remote to lock/open the car the first time.

Just insert the key that works with immobiliser, follow the steps to reprogram mode (6 quick turns within 10 secs and then press the keys as it is described in manual).After that, insert one by one the rest 3 keys and just press the keys as it is described in manual.

About the immobiliser for the rest 2 keys you have to call your dealer.

1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.