Nissan X-Trail Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
:frown: hi there ive only had my x trail a week and have already had to sort out a leak in the boot now i have another problem.

the temperature gauge on my 2.0 petrol normally sits just below half way when driving normally. but today i sat in traffic for no more than 3 minutes and the gauge went up to just under the red mark, then the fan kicked in and stayed on until i got home (about 2 miles).
im used to driving a diesel car and the gauge never moves.

can anyone tell me if this is normal on an x trail or if i need to take it back to where i got it and insert it where the sun doesnt shine as im fed up with it already.

many thanks

Dave :headbang:
 

·
Registered
Joined
·
1,452 Posts
Afraid thats not exactly normal behavior, especially in this cool weather. But dont despair, at least your cooling fan's taking care of things. There are 2 thermostats on these cars, possibly one of these is stuck.

The fact that the fan comes in shows that the ECU knows what temp then engine's at which is more than mine does!
Also the fact the fan cools things down means that the water pump is working and the rad isn't blocked.

If you have any warranty cover from the dealer, take it back and tell them to sort it. If you dont have any cover, take it back anyway and chance your arm, they might decide to be helpful!

Just make sure you have plenty water in it - make sure you top the radiator up and not the expansion tank!
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top