Nissan X-Trail Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
47 Posts
Discussion Starter · #1 ·
Hi there

Hello to you all and I am sure if this forum is like others I am a member of (Aprilia) I'll be inundated with help, and as I get used to the X-Trail I'll be able to offer some in return.

Anyway

I picked up my 55 plate with 50000 miles on the clock last Saturday.
After reading the posts, I looked under the bonnet and saw loads of oil on the front of the engine, so told the dealer to ensure whilst it was serviced to check for turbo failure.
On picking the car up they had fitted a brand new intercooler as they said it was leaking.
Now, why would there be oil in it if the turbo was not on its way out too........
Last night after a long run there is a definate "zzzzzzz" when I accelerate, I can also just about here the Turbo whine also, along with this noise, although the turbo noise is obviously only on acceleration when it kicks in - and TBH it's not that loud. What concerns me is the "whizzzzzz" noise I get alongside the turbo noise, it is RPM dependant, but as you decellerate it changes it's pitch along with the rpm.
Could this be turbo related, or is it something else- power steering pump?, water pump.

I will phone the dealer (West Way Nissan) who gave me a 12 month premier warranty with the vehicle.
It looks like the turbo has been replaced in the past, but I am not certain, it looks cleaner than the rest of the gubbins around that area.

Great vehicle by the way, but obviously want to ensure it stays that way whilst in warranty.
It's a Sept 05 Model, so still is within the turbo recall period of 5 years 90000 miles (I think)

At least I can tell the garage what I think is the problem.

Cheers in advance, and hello once again
 

·
Registered
Joined
·
47 Posts
Discussion Starter · #4 ·
Cheers all, as I guessed sensible responses.

I'll have the engine bay steam cleaned professionally and keep you posted of any developments.
As for the Westway - they are in Stourbridge and have been excellent so far, putting all the niggles (including the New Intercooler) right before I picked it up.

I have some wheel wobble when braking above 50mph, which I'll call them about tomorrow or Friday, but apart from that all good so far.

Stiggy - I have an RSV Factory 2004 model.

Cheers all.
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top