Nissan X-Trail Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
Hi, while driving home today our car just cut out and stopped ( QR20DE- engine type) the malfunction indicator light came on and so did the 4WD ( yellow) managed to restart and limp home on reduced power, phoned my local Nissan main agents who can put it on their diagnostic system in the middle of March- cant wait 6weeks- have started the engine since and only the malfunction indicator came on, so I risked a drive to a local garage and the engine cut out again, waited 10mins, restarted engine and limped home this time with the 4WD yellow light on , parked on the drive, there is a smell of burning :eek: , any ideas.......many thanks ..........alan
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #5 ·
hi, found a local garage who could plug their diagnostic equip into our car , 2 faults shown P0725 ( engine speed sensor) and P0335 ( crankshaft position sensor), faults cleared and car test driven, as soon as it gets to normal temp it cuts out ( same as if you have turned the ignition off) we it does restart the warning lights come back on and car in limp mode, plugged in to diagnostic equipment and NO faults listed, a faulty wire or connection now suspected, was also told that there was a recall by nissan to exchange these 2 sensors so I will check with my local dealer on monday to find out why ours hasnt been done.
 

·
Administrator
Joined
·
2,758 Posts
alanm said:
hi, found a local garage who could plug their diagnostic equip into our car , 2 faults shown P0725 ( engine speed sensor) and P0335 ( crankshaft position sensor), faults cleared and car test driven, as soon as it gets to normal temp it cuts out ( same as if you have turned the ignition off) we it does restart the warning lights come back on and car in limp mode, plugged in to diagnostic equipment and NO faults listed, a faulty wire or connection now suspected, was also told that there was a recall by nissan to exchange these 2 sensors so I will check with my local dealer on monday to find out why ours hasnt been done.
Hi Alan, glad managed to get it looked at and diagnosed to the two sensors need replacing. If you take a look at this link you'll see the recall is the first one.
link
viewtopic.php?f=42&t=1328

Hope everything works out OK with Nissan and that they can fit you in before middle of March as it was a recall and you weren't notified. :thumbs:

Umbongo
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top