It is currently Mon Apr 19, 2021 9:36 am

All times are UTC [ DST ]






Post new topic Reply to topic  [ 11 posts ]  Go to page 1, 2  Next
Author Message
 Post subject: Acceleration Issue
PostPosted: Fri Feb 09, 2018 11:07 am 
Offline
Soft Roader

Joined: Wed Oct 29, 2014 10:55 pm
Posts: 27
Location: Liverpool
Car:: Xtrail
Model: 2.2 Di
Year/Plate: 2003
Colour: blue
Mods: none
Hi All

Recently I have noticed on my wife's x trial that acceleration is almost non existent when driving the car until you get to about 2500 rpm at which point it seems to start to pull well. I have previously had to change the suction control valves on the car and also read about issue with throttle position sensor so dont think it is either of these.

Could this be a sign of turbo issues? Or should i be looking else where. The acceleration is not juddery so does not seem like a fueling issue.

Any ideas or test I can do to try narrow down the issue. Could it be the egr valve? Shall I have a go at cleaning that?

Thanks in advance


Top
 Profile Send private message  
 
X-Trail-UK.co.uk
Advertisement
 Post subject: Re: Acceleration Issue
PostPosted: Fri Feb 09, 2018 9:36 pm 
Offline
Extreme Off Roader

Joined: Sun Mar 06, 2016 9:08 pm
Posts: 498
Location: Swindon ,Wiltshire
Car:: Xtrail
Model: T31 Adventurer 2.0dci
Year/Plate: 08
Colour: Iridium Graphite
Mods: Safari lights
Change the fuel filter and the air filter and give the MAF sensor a clean first .Try that and see how you get on then report back.If it was the EGR then it's a fairly easy job to do even if it isn't that it might be worth cleaning anyway as it will need it eventually.


Top
 Profile Send private message  
 
 Post subject: Re: Acceleration Issue
PostPosted: Sat Feb 10, 2018 3:11 pm 
Offline
Off Roader

Joined: Fri Sep 29, 2017 5:19 am
Posts: 121
Location: Walsall. WM.
Car:: Xtrail
Model: Sport 2.2Di
Year/Plate: 2003
Colour: Blue
Mods: OBD2 please talk to me
Hi Mattrsa,

Personally i would just put injector cleaner in the fuel (low tank full bottle) then give it a run up and down the M/way in a lower gear, this will give your injectors and pump a good clean and should be back to norm.
Your injector pump doesn't start to reach full pressure until at +2500 rpm so any slight injector blockage is seen at a lower rev range. Sluggish pick up and also your turbo will start to spool up at approx same point so all happens at once.

Give it a go?
Ian


Top
 Profile Send private message  
 
 Post subject: Re: Acceleration Issue
PostPosted: Tue Feb 13, 2018 9:43 am 
Offline
Xtrail Nut
User avatar

Joined: Fri Aug 23, 2013 10:48 am
Posts: 1358
Location: NORTHUMBERLAND
Car:: Xtrail
Model: SPORT X 2.2DI with SAFARI LIGHTS
Year/Plate: 2003/53
Colour: ARUBA BLUE BW06
Mods: LED Internal and Number Plate lights. Double Din Parrot Audioline Stereo. Nightbreaker Headlight Bulbs. Rubber Boot Liner. Home Made Roof Rack for Safiri Roof Rails. Fire extinguisher. First Aid Kit. 12V tyre pump inflator.
Hi

From personal experience with the Di engine I would say this is down to the Maf, try cleaning it as already advised but if this does not work then just replace it. I know someone who also had the same issue as you, he cleaned his maf but the problem still persisted but after changing his fuel filter and suction control valves the problem still persisted, all in all it was a faulty maf sensor. Cleaning the sensor will not work 100% of the time but its worth trying it first before replacing it.

Cheers
Mike

_________________
Yesterday's History and tomorrow a mystery but today is a gift, it's why we call it the present.


Top
 Profile Send private message  
 
 Post subject: Re: Acceleration Issue
PostPosted: Tue Feb 13, 2018 10:30 am 
Offline
Extreme Off Roader
User avatar

Joined: Fri Jul 01, 2016 11:39 pm
Posts: 214
Location: Ireland
Car:: Xtrail
Model: T30 SXL 2Ltr petrol, Manual .2WD
Year/Plate: 2006
Colour: Silver (Dirty)
Mods: Leather seats , Bull bars , SS side steps , Towbar, Radio .CD, Mp3 , Bluetooth , Wife who knows everything.
This might help

https://www.youtube.com/watch?v=b4U_CGkS8ag


Top
 Profile Send private message  
 
 Post subject: Re: Acceleration Issue
PostPosted: Thu Feb 22, 2018 11:21 am 
Offline
Soft Roader

Joined: Wed Oct 29, 2014 10:55 pm
Posts: 27
Location: Liverpool
Car:: Xtrail
Model: 2.2 Di
Year/Plate: 2003
Colour: blue
Mods: none
Thanks for the replies

As suggested i have been adding diesel cleaner to the last few tanks but the issue has persisted resulting the the car going into limp mode this morning.
Will look into the Maf sensor replacement as find t hard to believe that the suction control valve have failed again after just two years.
Anyone got any links on replacing the maf sensor?


Top
 Profile Send private message  
 
 Post subject: Re: Acceleration Issue
PostPosted: Thu Feb 22, 2018 9:38 pm 
Offline
Soft Roader

Joined: Wed Oct 29, 2014 10:55 pm
Posts: 27
Location: Liverpool
Car:: Xtrail
Model: 2.2 Di
Year/Plate: 2003
Colour: blue
Mods: none
Well I watched the video and disconnected the Maf while the car was running and it made no difference. Is that a definative test to prove the Maf is faulty or not working?


Top
 Profile Send private message  
 
 Post subject: Re: Acceleration Issue
PostPosted: Thu Feb 22, 2018 10:53 pm 
Offline
Extreme Off Roader

Joined: Sun Mar 06, 2016 9:08 pm
Posts: 498
Location: Swindon ,Wiltshire
Car:: Xtrail
Model: T31 Adventurer 2.0dci
Year/Plate: 08
Colour: Iridium Graphite
Mods: Safari lights
Mattrsa wrote:
Thanks for the replies

As suggested i have been adding diesel cleaner to the last few tanks but the issue has persisted resulting the the car going into limp mode this morning.
Will look into the Maf sensor replacement as find t hard to believe that the suction control valve have failed again after just two years.
Anyone got any links on replacing the maf sensor?

Is EML on if so get the codes read.


Top
 Profile Send private message  
 
 Post subject: Re: Acceleration Issue
PostPosted: Thu Feb 22, 2018 11:22 pm 
Offline
Soft Roader

Joined: Wed Oct 29, 2014 10:55 pm
Posts: 27
Location: Liverpool
Car:: Xtrail
Model: 2.2 Di
Year/Plate: 2003
Colour: blue
Mods: none
No engine light

Tooom it to the garage last time this happened and there was no fault code.


Top
 Profile Send private message  
 
 Post subject: Re: Acceleration Issue
PostPosted: Sun Feb 16, 2020 7:45 am 
Offline
Newbie

Joined: Sat Jun 09, 2018 6:23 pm
Posts: 7
Location: Finland
Car:: Xtrail
Year/Plate: 2005
Colour: Silver
Old thread but did this problem ever get solved?
My xtrail is still feeling powerless under 2000rpm.
I haven't change maf and scv. Turbo and boost control valve has been changed.


Top
 Profile Send private message  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 11 posts ]  Go to page 1, 2  Next

All times are UTC [ DST ]


Who is online

Users browsing this forum: No registered users and 35 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group