It is currently Tue Nov 24, 2020 9:40 pm

All times are UTC [ DST ]






Post new topic Reply to topic  [ 3 posts ] 
Author Message
 Post subject: Heater output temperature not varying with controller
PostPosted: Sun Nov 15, 2020 11:08 am 
Offline
Soft Roader

Joined: Tue Sep 30, 2014 8:45 am
Posts: 76
Location: Cotswolds
Car:: Xtrail
Model: T30 Aventura
Year/Plate: 07
Colour: Silver Beige
Mods: Engine Pre-heater, Soundproofing, reversing sensors, COB reversing lights, Interior LED lights, Alpine DAB radio & aerial, Phillips Blue Vision Ultra headlight bulbs. Catch can, K&N air filter. Celtic tuning re-map.
I have an issue with the heater output in that the temp will not vary when attempting to adjust the temp with the heater controller.
If I turn the controller anticlockwise then it will discharge cold air and if I then move it clockwise to any position it will discharge hot air but will not blend the air.
My thoughts are that the fact that the discharge air goes from hot to cold would indicate the air mix flap motor is working and that it is possibly a faulty heater controller (which I presume is a rheostat or potentiometer) or the auto amp that controls the Air mix flap motor. From a diagram I have seen on the web there are several sensors that also affect the discharge temp.
Has anyone had this issue before?
Is the Auto amp located on the actual heater itself or just behind the heater controls?
Thanks for any help


Top
 Profile Send private message  
 
X-Trail-UK.co.uk
Advertisement
 Post subject: Re: Heater output temperature not varying with controller
PostPosted: Sun Nov 15, 2020 4:40 pm 
Offline
Xtrail Nut
User avatar

Joined: Mon Apr 02, 2012 2:09 pm
Posts: 2707
Location: Estonia
Car:: Xtrail
Model: T31 2.0dci auto, LE
Year/Plate: 2012
Colour: Grey
Mods: Towbar, ptc heater fix, probright drl system, Ebersp├Ącher aux FBH with GSM remote.
If you turn the temp knob from hot to cold or versa, you must hear air movement change. The autoamp is the same unit that has the knobs

_________________
Sorry for my bad english.


Top
 Profile Send private message  
 
 Post subject: Re: Heater output temperature not varying with controller
PostPosted: Mon Nov 16, 2020 10:54 pm 
Offline
Soft Roader

Joined: Tue Sep 30, 2014 8:45 am
Posts: 76
Location: Cotswolds
Car:: Xtrail
Model: T30 Aventura
Year/Plate: 07
Colour: Silver Beige
Mods: Engine Pre-heater, Soundproofing, reversing sensors, COB reversing lights, Interior LED lights, Alpine DAB radio & aerial, Phillips Blue Vision Ultra headlight bulbs. Catch can, K&N air filter. Celtic tuning re-map.
Thanks for your reply. Yes I have now found that out. I will remove the fascia and try to test it tomorrow. If it is the auto amp then I see there are a few used units on Ebay but would prefer to get a new one if I can but without going via Nissan who would no doubt be very expensive.


Top
 Profile Send private message  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC [ DST ]


Who is online

Users browsing this forum: No registered users and 62 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group