It is currently Mon Mar 01, 2021 11:05 am

All times are UTC [ DST ]






Post new topic Reply to topic  [ 57 posts ]  Go to page Previous  1, 2, 3, 4, 5, 6
Author Message
 Post subject: Re: X-trail from Estonia Vol.2 T31 2012 2.0Dci auto LE
PostPosted: Fri Jun 26, 2020 7:53 pm 
Offline
Xtrail Nut
User avatar

Joined: Mon Apr 02, 2012 2:09 pm
Posts: 2767
Location: Estonia
Car:: Xtrail
Model: T31 2.0dci auto, LE
Year/Plate: 2012
Colour: Grey
Mods: Towbar, ptc heater fix, probright drl system, Eberspächer aux FBH with GSM remote.
Was cleaning/ servicing brakes before new tires. Rear inner pads were scticking allready. Hope that Akebono slide pin boots are better than previous 3 sets i tried. Turned to hard plastic with in a year.
After that new rubber.

Attachment:
IMG_20200620_160929.jpg


Attachment:
IMG_20200620_160940.jpg


Attachment:
IMG_20200620_180957.jpg


While changing the tyres, as usual wigled the wheel 9/3 and feeled a play in the front left lower joint. Last year i changed the both control arms, Lemfjörder.
Hope to get away with only changing the joint.

Also it sounds that the same wheel bearing makes noise.


You do not have the required permissions to view the files attached to this post.

_________________
Sorry for my bad english.


Top
 Profile Send private message  
 
X-Trail-UK.co.uk
Advertisement
 Post subject: Re: X-trail from Estonia Vol.2 T31 2012 2.0Dci auto LE
PostPosted: Sat Jul 04, 2020 4:14 pm 
Offline
Xtrail Nut
User avatar

Joined: Mon Apr 02, 2012 2:09 pm
Posts: 2767
Location: Estonia
Car:: Xtrail
Model: T31 2.0dci auto, LE
Year/Plate: 2012
Colour: Grey
Mods: Towbar, ptc heater fix, probright drl system, Eberspächer aux FBH with GSM remote.
As i said, the joint had a play. Pressing the old out.


Attachment:
IMG_20200704_141213.jpg


Attachment:
IMG_20200704_143029.jpg


Have to say, new joint is also lemförder, but it felt a bit soft after pressing it in. Maybe I did something wrong.

Also the wheelbearing made noise.
Attachment:
IMG_20200704_154804.jpg

Out with it.


You do not have the required permissions to view the files attached to this post.

_________________
Sorry for my bad english.


Top
 Profile Send private message  
 
 Post subject: Re: X-trail from Estonia Vol.2 T31 2012 2.0Dci auto LE
PostPosted: Sat Jul 04, 2020 4:24 pm 
Offline
Xtrail Nut
User avatar

Joined: Mon Apr 02, 2012 2:09 pm
Posts: 2767
Location: Estonia
Car:: Xtrail
Model: T31 2.0dci auto, LE
Year/Plate: 2012
Colour: Grey
Mods: Towbar, ptc heater fix, probright drl system, Eberspächer aux FBH with GSM remote.
And out it is.
Attachment:
IMG_20200704_154813.jpg


Followed this video
https://youtu.be/MAb5_xgKia4

But i have to say that the abs wheel sensor does not come off 99% of times. If you do this, or visit a shop the buy the sensor. Like 18€
Unfortunally i forgot to buy the sensor, and it is saturday. So, no 4wd for me for few days.
Plently tutorial videos on yt how to drill out an abs sensor.

Have to hold back with the gas pedal because torque and tyre squeeks


You do not have the required permissions to view the files attached to this post.

_________________
Sorry for my bad english.


Top
 Profile Send private message  
 
 Post subject: Re: X-trail from Estonia Vol.2 T31 2012 2.0Dci auto LE
PostPosted: Tue Dec 29, 2020 9:44 am 
Offline
Xtrail Nut
User avatar

Joined: Mon Apr 02, 2012 2:09 pm
Posts: 2767
Location: Estonia
Car:: Xtrail
Model: T31 2.0dci auto, LE
Year/Plate: 2012
Colour: Grey
Mods: Towbar, ptc heater fix, probright drl system, Eberspächer aux FBH with GSM remote.
Long time no input.
If you have read this "blog", then you know that my X-trail is haunted with an electrical problem.
Randomly, (when usin cruise, the moust) the Interior lights come on for 2 sec and the BCM goes to failsafe mode. That means the main beams come on, no wipers(but the washer works), No side indicators on the dash(but they work luckly), The autobox loses the torque converter clutch, some times the ESP off and Slip light come on too.
When I stop the car, key off and start the the car again, Everything is ok. Sometimes for 2 minutes, sometimes 1 day, sometimes a week, or even a month.
I changed the clock spring, because the cruise often bring that problem up, and on a very humid day, the radio buttons did not work on the steering wheel. Was like 15€ from Ali. But the problem came still up.

Then ordered an used IPDM(Intelligent Power Distribution Module), that also controlls everything electrical, but that did not help.

Then I thougth that the LED DRL lights could generate an electrical/digital noise. Disabled them and for a while, id was ok.
Next tought was the Pioner aftermarket radio. Sometimes just before when the problem occured and i was listening music from youtube via BT, then YT would go pause and when resuming, the problem was there.
So drove with engine and cabin noises for 3 weeks, but eventually it came up again.

When I plug in the scanner, then the only module, that i can not talk is the BCM. I removed it, opened the case, soaked the PCB with contact cleaner, cleaned the pins and so on.
Bite the bullet and searced for a new bcm. It has to be with the same part number, because the wiring and the connectors may be different.
Found it in Poland from a Qashqai, 50-60€
My delphi DS150 can not program keys, so I ordered a Thinkdiag+ scanner from Ali that uses a Phone app. It is like Launch x491.
It programmed the keys with no problems and had to enable front headlight washers, but the rear wiper stop position is different. Tried to reprogram the BCM like a New BCM and select options manually but the scanner failed. Can live with wiper in 2 oclock, not on 3 like it was.
Touch wood, no problems within 2 days, maybe it is to soon to celebrate but will see how it goes.

If it solved my problems and the wiper arm starts to get annoing, then go tho the dealer and reprogramm it there.
I will play with the Thinkdiag+, maybe I can copy the old BCM settings and write them to the new used one.

I will keep You Updated.

_________________
Sorry for my bad english.


Top
 Profile Send private message  
 
 Post subject: Re: X-trail from Estonia Vol.2 T31 2012 2.0Dci auto LE
PostPosted: Thu Jan 14, 2021 8:49 am 
Offline
Xtrail Nut
User avatar

Joined: Mon Apr 02, 2012 2:09 pm
Posts: 2767
Location: Estonia
Car:: Xtrail
Model: T31 2.0dci auto, LE
Year/Plate: 2012
Colour: Grey
Mods: Towbar, ptc heater fix, probright drl system, Eberspächer aux FBH with GSM remote.
With the replacement bcm, it did the same.
I suspected the aftermarket pioneer stereo from the beginning.
Before new year eve I was on the way for a hair cut with my son and took some cash from ATM. He was in the car and when i returned from the atm, stereo reconnected my phone and right then it happened again.
Next day i removed everything that was connected with the stereo, included wires. The stereo has its own canbus box
Attachment:
IMG_20210114_091347.jpg


It has the steeringwheel controls, reverse signal, vss, and something more from that.And it was wired to canbus lines on the obd2 connector. First thing I disconnected the canbus wires, but it still acted up. Then i ripped everything out.
Droved like this for 2weeks after that i got bored from depeche mode- enjoy the silence. Good song tough.
Reconnected the stereo without the small canbus box.
Stereo works, but without stw controls, and the buttons do not have illumination.
A week with this setup, and had no problems yet.


You do not have the required permissions to view the files attached to this post.

_________________
Sorry for my bad english.


Top
 Profile Send private message  
 
 Post subject: Re: X-trail from Estonia Vol.2 T31 2012 2.0Dci auto LE
PostPosted: Mon Jan 25, 2021 4:38 pm 
Offline
Xtrail Nut
User avatar

Joined: Mon Apr 02, 2012 2:09 pm
Posts: 2767
Location: Estonia
Car:: Xtrail
Model: T31 2.0dci auto, LE
Year/Plate: 2012
Colour: Grey
Mods: Towbar, ptc heater fix, probright drl system, Eberspächer aux FBH with GSM remote.
My cabin blower started to make noise a week a go.

Ok, bearings are toasted. But it failed completly on saturday. Basically no flow from vents. Luckly no frost, but windows begun to fog up.
A local parts store had a an Aftermarket NRF Brand QashQai blower unit in stock and from the parts nubmers it should fit.
Service manual says that the Dash has to come out :headbang: :bigcry: , but Youtube shows that there is a way around.
The UK folks have it easy. The rest have to remove the pedal assembly. No big deal.
When I reached the the part to twist the housing counter clockwise, it was stuck. Watched the videos again, if threre is a hidden trick or sometring, but just turn it and it comes off. Only on videos.

Then i went to nearby small engine repair shop to see if they have this type on oil filter wrench. Yes, they did and they let me borrow it.

Image

It was pretty tight. even with the ratchet.
Ok old out and just quit check of wire polarity, You never know the aftermarket guys. OEM plugger direct on the case, the aftermarket one had like 5cm wires and then the connector. Polarit was ok, then back together. But it not want to go in to the HVAC box. :bigcry:. Turns out that the aftermarket one has a lip on the edge of the turbone ot self. It is 2mm bigger that the oem.
Wanted to swap turbines, but the aftermartet one was press fit and did not want to break it. OEM one had a nut on it and the shaft is slotted.
So luckly I have a bench grinder and just let the lip toutch the spinning grinding wheel to get the turbine to spin too, then I tilted the blower so it will grind the lip smaller and it did not loose it balance.
Now it went in and but everything back together.
Nice to have heat in the cabin now.

_________________
Sorry for my bad english.


Top
 Profile Send private message  
 
 Post subject: Re: X-trail from Estonia Vol.2 T31 2012 2.0Dci auto LE
PostPosted: Fri Feb 19, 2021 10:30 am 
Offline
Xtrail Nut
User avatar

Joined: Mon Apr 02, 2012 2:09 pm
Posts: 2767
Location: Estonia
Car:: Xtrail
Model: T31 2.0dci auto, LE
Year/Plate: 2012
Colour: Grey
Mods: Towbar, ptc heater fix, probright drl system, Eberspächer aux FBH with GSM remote.
I installed a Saftey hazard
https://www.youtube.com/watch?v=o0XunbtcoB0

https://www.youtube.com/watch?v=djGHFU2ZQos

https://www.aliexpress.com/item/4000393 ... 4c4dnohg9S

And ordered the Nissan harness from the same seller. Rest was Plug and Play.

_________________
Sorry for my bad english.


Top
 Profile Send private message  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 57 posts ]  Go to page Previous  1, 2, 3, 4, 5, 6

All times are UTC [ DST ]


Who is online

Users browsing this forum: No registered users and 12 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group