It is currently Sun Aug 01, 2021 12:12 pm

All times are UTC [ DST ]






Post new topic Reply to topic  [ 14 posts ]  Go to page Previous  1, 2
Author Message
 Post subject: Re: Help - holiday in T32 with ventilation issue
PostPosted: Sat Jan 11, 2020 11:15 am 
Offline
Newbie

Joined: Fri Mar 24, 2017 11:48 pm
Posts: 14
Location: Norway
Car:: X-trail
Model: 1.6dci 4WD Tekna 7s
Year/Plate: 2015
Colour: Black
An update on this. In my case, they had to replace parts of the AC to fix the problem. Don't remember exactly what they replaced - think it was the condenser at least.

Since the fix was performed during the fall last year, there was never really any weather afterwards that let me test if the performance for the AC now is ok...


Top
 Profile Send private message  
 
X-Trail-UK.co.uk
Advertisement
 Post subject: Re: Help - holiday in T32 with ventilation issue
PostPosted: Sun May 09, 2021 3:10 pm 
Offline
Newbie

Joined: Fri Mar 24, 2017 11:48 pm
Posts: 14
Location: Norway
Car:: X-trail
Model: 1.6dci 4WD Tekna 7s
Year/Plate: 2015
Colour: Black
Just an update to an old thread. In my case, mentioned above, they replaced the AC-radiator from what I understood (was a leak). Solved the problem.


Top
 Profile Send private message  
 
 Post subject: Re: Help - holiday in T32 with ventilation issue
PostPosted: Mon May 24, 2021 1:40 pm 
Offline
Newbie

Joined: Mon Apr 13, 2015 3:25 pm
Posts: 13
Location: Ilford
Car:: Xtrail
Model: Accenta +
Year/Plate: 2015
Colour: Storm White
I had this problem after the first year of ownership of my 15 plate T32. At its service they re-gassed the aircon and it was fine for a few weeks. Weather was rubbish so didn't bother too much with it. Following year there was no Cold AirCon so left the car with the dealer, and they put a colour in the system to see if any leaks.
Turned out to be a split on the corner of the AC condenser, and was authorised to replace under warranty.
Thankfully its been fine since then.


Top
 Profile Send private message  
 
 Post subject: Re: Help - holiday in T32 with ventilation issue
PostPosted: Thu Jul 15, 2021 2:57 pm 
Offline
Newbie

Joined: Fri Mar 24, 2017 11:48 pm
Posts: 14
Location: Norway
Car:: X-trail
Model: 1.6dci 4WD Tekna 7s
Year/Plate: 2015
Colour: Black
mrsee wrote:
Just an update to an old thread. In my case, mentioned above, they replaced the AC-radiator from what I understood (was a leak). Solved the problem.


An update here again. The above work was done in October 2019. But the AC issue is now back. After an hour of driving, the AC has basically no effect. Sort of suspect the real issue was never fixed in a good way or there was multiple leaks, but that the AC worked ok for a while as long as there was enough gas left in the system. Could be that the problem have been there for a while now, but with the whole Covid-situation the car havn't been used for longer trips since last summer - at least not in hot weather.

Car out of warranty now, but with the Norwegian customer rights, there is a new complaint period for 5 years on repairs that have been done.


Top
 Profile Send private message  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 14 posts ]  Go to page Previous  1, 2

All times are UTC [ DST ]


Who is online

Users browsing this forum: No registered users and 29 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group