UK Nissan X-Trail Owners Forum
https://www.x-trail-uk.co.uk/

Hi all
https://www.x-trail-uk.co.uk/viewtopic.php?f=26&t=81207
Page 1 of 2

Author:  T30Olly [ Sun Sep 06, 2020 10:36 pm ]
Post subject:  Hi all

Hi all lee from Newcastle

This is my first xtrail its the 2.2 2005 SE

Bought it to tow my track car so my intentions are to give it a good service and a tidy up then hopefully it can start doing some work.

Ran into a few issues but hopefully solved! The common no power limp mode no light situation showing no fuel pressure p1273 p0089. So I pulled the fuel filter and it was clogged solid with gunk! So I'm hoping tomorrow I'll get a new filter and all will be good!

Also pulled the SCV (which looked pretty new) and gave it a good clean with contact cleaner

Author:  Umbongo [ Sun Sep 06, 2020 10:49 pm ]
Post subject:  Re: Hi all

Welcome to the forum :thumbs:
Umbongo

Author:  rufusbarry [ Mon Sep 07, 2020 12:27 am ]
Post subject:  Re: Hi all

T30Olly wrote:
Hi all lee from Newcastle

This is my first xtrail its the 2.2 2005 SE

Bought it to tow my track car so my intentions are to give it a good service and a tidy up then hopefully it can start doing some work.

Ran into a few issues but hopefully solved! The common no power limp mode no light situation showing no fuel pressure p1273 p0089. So I pulled the fuel filter and it was clogged solid with gunk! So I'm hoping tomorrow I'll get a new filter and all will be good!

Also pulled the SCV (which looked pretty new) and gave it a good clean with contact cleaner
Welcome to the Forum Lee The members here have helped me many many times and the crack is good.I used to go to Newcastle in the sixties when i lived in CarlisleGood Luck Barry

Author:  leafy [ Mon Sep 07, 2020 7:07 am ]
Post subject:  Re: Hi all

T30Olly wrote:
Hi all lee from Newcastle

This is my first xtrail its the 2.2 2005 SE

Bought it to tow my track car so my intentions are to give it a good service and a tidy up then hopefully it can start doing some work.

Ran into a few issues but hopefully solved! The common no power limp mode no light situation showing no fuel pressure p1273 p0089. So I pulled the fuel filter and it was clogged solid with gunk! So I'm hoping tomorrow I'll get a new filter and all will be good!

Also pulled the SCV (which looked pretty new) and gave it a good clean with contact cleaner

Hello and welcome .Be interesting to know why the fuel filter is full of c**P ,was it just left to long before a change or is dirty fuel getting in the tank .The tanks are plastic so no chance of rust .

Author:  T30Olly [ Mon Sep 07, 2020 8:54 am ]
Post subject:  Re: Hi all

Cheers all! Seems like the forum is pretty active so that's always a positive.

I'm not sure ive just bought it so bad servicing I think

Author:  Bus-man [ Mon Sep 07, 2020 12:00 pm ]
Post subject:  Re: Hi all

Hi and welcome. Lots of useful chat on here as I'm sure you'll find out.

Author:  bertye [ Mon Sep 07, 2020 6:02 pm ]
Post subject:  Re: Hi all

Hi, see you managed to get on. The pictures you sent me last night, well the most clogged up filter I have ever seen. It does look like old vegetable oil was used in it.

Author:  Colster [ Tue Sep 08, 2020 8:57 am ]
Post subject:  Re: Hi all

bertye wrote:
Hi, see you managed to get on. The pictures you sent me last night, well the most clogged up filter I have ever seen. It does look like old vegetable oil was used in it.


Not good. They are bad enough with refined diesel!

@Bertye. Please let me know if you can supply a T30 tailpipe.

Author:  T30Olly [ Tue Sep 08, 2020 10:31 pm ]
Post subject:  Re: Hi all

Yeah the filter was pretty bad! Still haven't bled it yet been far to busy hopefully get it started tomorrow and see how it runs...fingers crossed

Author:  T30Olly [ Wed Sep 09, 2020 7:29 am ]
Post subject:  Re: Hi all

How do you post up pictures? I've tried using an image host and copying the link across but whe I click preview it just shows the link

Page 1 of 2 All times are UTC [ DST ]
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/