It is currently Sun May 09, 2021 2:21 pm

All times are UTC [ DST ]






Post new topic Reply to topic  [ 3 posts ] 
Author Message
 Post subject: Pump relearn needed ?
PostPosted: Wed Dec 20, 2017 10:40 pm 
Offline
Soft Roader

Joined: Sun Nov 22, 2015 10:12 pm
Posts: 39
Location: Chesterfield
Car:: Xtrail
Model: T30 2.2di
Year/Plate: 2003
Hi All,
I have an 03 plate T30 X trail,2.2 DI, with twin suction valve type injection pump,
I have replaced the valves, does it need a re learn ? If so how do I do it,
I have read a few versions on tinternet to reset pump and get mil light flashing on the dash, but none have worked for me.
I had a garage stick the diagnostic machine on , and that showed no faults or anything strange, but not sure if it would talk to the version of consult needed ?
It has a flat spot /low torque below 2000 , after that goes like a train, nice clean , no smoke, but the low torque at low revs bugs me..
EGR has been blocked and engine breather re routed to keep things clean,, :biggrin:
Any advice please....

Cheers


Top
 Profile Send private message  
 
X-Trail-UK.co.uk
Advertisement
 Post subject: Re: Pump relearn needed ?
PostPosted: Thu Dec 21, 2017 1:04 am 
Offline
Site Admin

Joined: Fri Oct 30, 2009 5:14 pm
Posts: 2763
Location: North West U.K.
Car:: Xtrail
Model: 2.2 Di Sport(T30 - YD22ETI) Trans MT.F6
Year/Plate: Dec 51
Colour: Red AX6
No need for relearn on that pump :thumbs:


Top
 Profile Send private message  
 
 Post subject: Re: Pump relearn needed ?
PostPosted: Thu Dec 21, 2017 2:18 pm 
Offline
Off Roader

Joined: Fri Sep 29, 2017 5:19 am
Posts: 121
Location: Walsall. WM.
Car:: Xtrail
Model: Sport 2.2Di
Year/Plate: 2003
Colour: Blue
Mods: OBD2 please talk to me
No relearn required, most like fault will be the injectors slightly blocked,
I had the same or similar fault that the car didn't pickup smoothly at low rev's noticeable 1st 2nd gear, if you put your foot down it would go like the clappers, the other issue i had was when in 4th 5th or 6th gear holding a steady speed or rev range the car would seem to miss fire again put your foot down and away it would go?
So I've recently added a full bottle of cleaner to a low tank and driven the car on high rev's on A roads / motorways and it seems to have cleared my fault?
But i only drive it on the weekends and not fully tested it as yet.

Ian


Top
 Profile Send private message  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC [ DST ]


Who is online

Users browsing this forum: No registered users and 12 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group