It is currently Mon Sep 21, 2020 7:43 pm

All times are UTC [ DST ]






Post new topic Reply to topic  [ 17 posts ]  Go to page Previous  1, 2
Author Message
 Post subject: Re: Android head unit
PostPosted: Sat Mar 30, 2019 12:01 am 
Offline
Off Roader

Joined: Sun Sep 09, 2018 6:20 pm
Posts: 118
Car:: Xtrail
Model: T31 2.5 CVT 4wd
Year/Plate: 2011
Presumably your HU has a steering wheel 'learning' mode/screen?... if so then I doubt you'll need an 'interface' ...just connect A & B ..up to..A n B ..and 'teach' your unit what is what ...
you may possibly need the earth line too.. but unlikely


Top
 Profile Send private message  
 
X-Trail-UK.co.uk
Advertisement
 Post subject: Re: Android head unit
PostPosted: Wed Apr 03, 2019 8:14 pm 
Offline
Soft Roader

Joined: Mon May 02, 2016 12:46 pm
Posts: 96
Location: West Yorkshire
Car:: Xtrail
Model: 2.0 Aventura T31
Year/Plate: 2009
Colour: grey
Hey guys just an update on this, and a call for help!

So everything is in and working, apart from rear view camera. Steering controls no problem, modified the facia a smidge to fit the stereo (dremel tool job).

I thought I had hit the jackpot when i found an adapter for the reverse camera, they call it a Reverse Camera Retention kit. The guy on ebay check with me the year, make and model of the car and the stereo fitted to it, all seemed ok. I came to fit it ad nothing. I have hooked up the RCA for the camera, reverse signal from the head unit to the wire on the kit and the ground. I get less than 2volts at the reverse signal, and of course the camera does not switch on. Initially i noticed an exclamation mark but figured that was down to my ground which had come loose, fixed that and the exclamation went away.

Ive asked the ebay seller for clues, but no reply as yet, i am wondering if anyone here has any ideas?

this is the connector I bought.. https://www.ebay.co.uk/itm/4-Camera-528 ... %7Ciid%3A1

it directly fits to the car connector that usually goes in the back of the factory sat nav screen.


Top
 Profile Send private message  
 
 Post subject: Re: Android head unit
PostPosted: Thu Apr 04, 2019 3:08 am 
Offline
Off Roader

Joined: Sun Sep 09, 2018 6:20 pm
Posts: 118
Car:: Xtrail
Model: T31 2.5 CVT 4wd
Year/Plate: 2011
do you have 12v at the camera itself? ... does the camera get its 12v via this 'kit' ..rather thro a seperate external supply like reverse lights?

if it is supposed to get its 12v via this 'kit' then of course it wont work with only 2v present ..as you correctly say.

How does the Head Unit detect reverse gear? ... there must be a 'reverse' input to the head unit ..for it to then output it to the camera.....


Top
 Profile Send private message  
 
 Post subject: Re: Android head unit
PostPosted: Thu Apr 04, 2019 11:26 am 
Offline
Soft Roader

Joined: Sat Mar 23, 2013 8:18 pm
Posts: 23
Location: Dumfries
Car:: Xtrail t31
Model: 2.0 dci adventura
Year/Plate: 09
Colour: black
Mods: led cabin lights, andriod head unit(nearly done :-)
I had issuies with the reverse camera interface i got too, had +12v on the switch line all the time, could not get it to work, in the end got a xtrons reverse camera kit.

i sat in the cabin and connected it all up to check it worked, also to find which connectors to use on the radio, have quite a few to choose from. checked the +12v line and camera picture worked ok.

then took out the original camera and replaced, took power feed from the reverse light, that switces on the camera and +12v feed switches the head unit over, would rather have kept the original but just not work for me, got my steering wheel controls working too.

kenny


Top
 Profile Send private message  
 
 Post subject: Re: Android head unit
PostPosted: Thu Apr 04, 2019 2:55 pm 
Offline
Soft Roader

Joined: Mon May 02, 2016 12:46 pm
Posts: 96
Location: West Yorkshire
Car:: Xtrail
Model: 2.0 Aventura T31
Year/Plate: 2009
Colour: grey
cheers Kenny

I do need to check the voltage at the camera but as far as I know the camera should get its power from the loom at the head unit. I would be surprised if the camera gets its power via the reverse light. The reverse light is in the bumper, and the camera is on the boot.

I will email the seller one more time, if no response then ill get ebay to sort out a refund :(


Top
 Profile Send private message  
 
 Post subject: Re: Android head unit
PostPosted: Thu Apr 04, 2019 10:46 pm 
Offline
Soft Roader

Joined: Sat Mar 23, 2013 8:18 pm
Posts: 23
Location: Dumfries
Car:: Xtrail t31
Model: 2.0 dci adventura
Year/Plate: 09
Colour: black
Mods: led cabin lights, andriod head unit(nearly done :-)
the original camera will get power thru the loom, a after market camera tho, have took a feed from the reverse light, powers the camera ans sends 12v back for switching the head unit, might have confused you :biggrin:


Top
 Profile Send private message  
 
 Post subject: Re: Android head unit
PostPosted: Fri Apr 05, 2019 7:57 am 
Offline
Soft Roader

Joined: Mon May 02, 2016 12:46 pm
Posts: 96
Location: West Yorkshire
Car:: Xtrail
Model: 2.0 Aventura T31
Year/Plate: 2009
Colour: grey
no i get you - i fitted a similar system to my T30 xtrail, admittedly a much easier job as the reverse lights are on the side so running the cables was much easier.

I think if i cant get this problem fixed using the adapter (which apparently is a Connects2 adapter, so ive contacted them) ill run a new aftermarket camera :(


Top
 Profile Send private message  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 17 posts ]  Go to page Previous  1, 2

All times are UTC [ DST ]


Who is online

Users browsing this forum: No registered users and 6 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group