Switch to full site
Click here to find out more about ICE, Satellite Navigation, Telecoms etc
Post a reply

Display Fault

Mon Aug 03, 2020 5:14 pm

My 2009 X-Trail has suddenly displayed a fault on the display.

Has been fine since I bought it from new - but suddenly looks like this:-

Image

?? Don't know why the image does not display - it's HERE

:bigcry:

It's like this all the time now.

Any idea?

How do I fix it??

Please help.

Re: Display Fault

Mon Aug 10, 2020 4:15 pm

Oh dear - lots of views and no one has any ideas :bigcry:

???

Re: Display Fault

Mon Aug 10, 2020 9:50 pm

John Willett wrote:Oh dear - lots of views and no one has any ideas :bigcry:

???


I'm one of your voyeurs, but don't know the answer I'm afraid. I suppose there could be a loose connection, but that does look like a cooked display to me.

Re: Display Fault

Mon Aug 10, 2020 11:03 pm

I've been following too, but I'm not much help either. I've never had a car with a sat-nav before, but now I have one with what looks like the same sort of display. I'm watching with interest as if someone does indeed know what the problem is I will make a note of it in case I get the same problem at any point. I hope it's nothing serious and you manage to get it sorted soon.
Colin

Re: Display Fault

Tue Aug 11, 2020 9:46 am

Just guessing, but looks similar to a problem on my daughters old laptop. On hers the disruption followed a binary pattern, ie repeated at 2, 4, 8, 16 intervals. I pulled it apart and found a "sticky bit". One of the screen address lines was not switching. Proved to be one of those rubberised contact strips. Dismantled and carefully cleaned it. Took a couple of attempts, but once clean and properly assembled, the problem went away.

Re: Display Fault

Tue Aug 11, 2020 12:10 pm

Has it been subject to these high temps we've been having?

Have you updated anything at all? Try putting your Sat Nav DVD into the slot and see if it does anything?

Does it make any difference if you try switching to radio or USB?

Re: Display Fault

Fri Aug 14, 2020 1:30 pm

If I remove the SatNav X7 DVD completely, the marks are still on the screen, so it's not the DVD.

I have discovered that sometimes the marks are lighter and sometimes darker.

Thanks for the comments so far.
Post a reply