Switch to full site
Post any questions about modifying your Engine, Gearbox, Exhaust or Braking System. Feel free to include links to other companies or products
Post a reply

Using LEDs in the T31

Sun Feb 10, 2013 9:21 am

I am looking to replace the front sidelights with LEDs in the T31 (2012) and maybe later the reversing lights so do I need canbus compatible ones?

I have also heard that changing the indicators over to LED's can cause issues with the flash rate. Has anyone found this to be a problem?

Re: Using LEDs in the T31

Sun Feb 10, 2013 11:11 am

I have fitted some led type (front) sidelights to my 2007 T31. I wasn't aware at the time that I *might* need CANBUS compatible ones, but I think the ones supplied were anyway. They work without problems. I bought them off of eBay for about £5 for a pair (don't know what that translates to in NZ though).

As far as the indicators go, I haven't changed mine yet and will probably wait until a bulb blows, so I don't know on that one.

Just another note - if you buy CANBUS compatible ones and it doesn't need them, I think they should still work.

Re: Using LEDs in the T31

Sun Feb 10, 2013 11:15 am

I used non-CANBUS LEDs in ours and works fine.

Aitch

Re: Using LEDs in the T31

Mon Feb 11, 2013 4:26 am

Yes Me also.I changed all the interior lights to Led,s and have had no problems.
:biggrin:

Re: Using LEDs in the T31

Tue Feb 19, 2013 6:11 am

I have updated the side lights with 1W 5-LED 6500K LEDs. Photo shows left hand side (in photo) with LED's and right hand side with the standard bulbs.
You do not have the required permissions to view the files attached to this post.

Re: Using LEDs in the T31

Tue Jul 30, 2013 6:40 pm

Is it possible to do this with indicators and brake lights as well?

Re: Using LEDs in the T31

Tue Jul 30, 2013 9:00 pm

Hi, Ive done nearly all mine on my 08 reg T31 ( sidelights, Fogs, reverse, Brake, Tail, indicators ) just got the headlights to do but waiting till they pop. On the pre facelift you dont need to worry about canbus as we dont have the computer to tell you that you have a bulb out unlike the newer shape, the only problem i had was the indicators as the flash rate was too fast but I just fitted the inline resistors and that slowed the flash rate to normal
Post a reply