It is currently Sun May 09, 2021 12:09 am

All times are UTC [ DST ]






Post new topic Reply to topic  [ 3 posts ] 
Author Message
 Post subject: Possible alternator problem.
PostPosted: Sat Jan 16, 2021 12:40 pm 
Offline
Newbie

Joined: Thu May 12, 2011 5:27 pm
Posts: 18
Hi
Few months a go I was driving home from an appointment and suddenly all the dash lights started blinking, the radio also. I then stopped the car tried to start it and you guessed flat battery. Managed to get a jump start and car was fine for few weeks. Then it happened again this time the alt. Belt got hot and made e the squeals. Got home checked out put from alt. It was 14.4,charged battery and after overnight charge on bench left battery a few hrs to check output that was 12.73 standing. Put battery back on everything went fine until today. This time I had a multimeter with me. Checked the alt. during the flickering and it was only 8.45 output, checked battery that was same. Is this a typical alt. problem or could there be another cause? Reason i ask is I live in Norway and the price of a new 1 is around 4000 kr(400) pounds. I just don't want to use money if it is another reason
The alt is original to my 2006 dci xtrail(t30) Battery is a few years old only.


Top
 Profile Send private message  
 
X-Trail-UK.co.uk
Advertisement
 Post subject: Re: Possible alternator problem.
PostPosted: Sat Jan 16, 2021 2:47 pm 
Online
Xtrail Nut

Joined: Wed Aug 29, 2018 2:16 pm
Posts: 632
Car:: Xtrail
Model: 2.2 DCi Columbia
Year/Plate: 2006 '06
Colour: Silver
Mods: LED Sidelight bulbs!
If belt was squealing, it was slipping. When it slips, alternator output is reduced. Try adjusting or replacing alternaror belt and see if that improves output. Also make sure all earth connections between engine and body are sound - clean and tight. When testing output from alternator, put system under load. Headlights, heated rear window and heater blower on low speed. Is there nowhere to have alternator repaired if necessary?


Top
 Profile Send private message  
 
 Post subject: Re: Possible alternator problem.
PostPosted: Wed Jan 27, 2021 11:44 pm 
Offline
Extreme Off Roader
User avatar

Joined: Sat Apr 03, 2010 10:35 pm
Posts: 230
Location: Sydney, Australia
Car:: Xtrail
Model: T30 Ti Series 1
Year/Plate: 2003
Colour: Silver
Mods: Too many to list here :o) See my ride from my signature link
Check the drivebelt tensioner. It may not be free enough to keep the belt tensioned or the bearing in the pulley could be faulty causing both the squeal you hear and drag on the belt to slow the alternator down.

Checking under as much electrical load as you can is a great idea from @Colster since this could help diagnose a rectifier diode going bad. Measure AC voltage also on the alternator to help check for faulty diodes.

_________________
Image
Kev.
My ride
My Blog


Top
 Profile Send private message  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC [ DST ]


Who is online

Users browsing this forum: No registered users and 35 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group