It is currently Fri Mar 05, 2021 1:41 pm

All times are UTC [ DST ]






Post new topic Reply to topic  [ 17 posts ]  Go to page 1, 2  Next
Author Message
 Post subject: ECU reset not working
PostPosted: Mon Oct 14, 2019 3:32 pm 
Offline
Off Roader

Joined: Tue Apr 16, 2019 2:03 pm
Posts: 118
I tried the pedal reset as detailed here https://www.x-trail-uk.co.uk/viewtopic. ... start=0url
But it doesn't seem to work. I have a 2006 Aventura 2.2 diesel. Does this have the wrong engine for this reset?

_________________
Malc

Old enough to know better


Top
 Profile Send private message  
 
X-Trail-UK.co.uk
Advertisement
 Post subject: Re: ECU reset not working
PostPosted: Mon Oct 14, 2019 5:58 pm 
Offline
Xtrail Nut

Joined: Wed Aug 29, 2018 2:16 pm
Posts: 602
Car:: Xtrail
Model: 2.2 DCi Columbia
Year/Plate: 2006 '06
Colour: Silver
Mods: LED Sidelight bulbs!
That should work. What isn't working. Does the MIL flash?


Top
 Profile Send private message  
 
 Post subject: Re: ECU reset not working
PostPosted: Mon Oct 14, 2019 7:00 pm 
Offline
Off Roader

Joined: Tue Apr 16, 2019 2:03 pm
Posts: 118
The MIL doesn't flash. It lights up when you turn the ignition on so I know the bulb is ok.

_________________
Malc

Old enough to know better


Top
 Profile Send private message  
 
 Post subject: Re: ECU reset not working
PostPosted: Mon Oct 14, 2019 8:22 pm 
Offline
Extreme Off Roader

Joined: Sun Mar 06, 2016 9:08 pm
Posts: 494
Location: Swindon ,Wiltshire
Car:: Xtrail
Model: T31 Adventurer 2.0dci
Year/Plate: 08
Colour: Iridium Graphite
Mods: Safari lights
Changed my SCV on my 06 dci the other day and used this and it works


To carry out the reset carry out the following

Turn ignition on so all dash lights come on.

Wait 3 seconds

PUMP accelerator pedal 5 times within 5 seconds....

with foot now OFF accelerator wait 7 seconds...

After 7 seconds press and hold down accelerator pedal for 10 seconds...

After 10 seconds the Engine Management Light will start to flash, at this point remove foot from accelerator.

The ECU is now in diagnostic mode, so let the EML flash for a bit. the press and hold the accelerator pedal down for more than 10 seconds..this will then reset ECU and fuel pump etc......and put them into learning mode.

Error Codes: When the EML light is flashing, this is listing possible fault codes



Take the Xtrail out for a drive making good use of the gears and engine .


Top
 Profile Send private message  
 
 Post subject: Re: ECU reset not working
PostPosted: Mon Oct 14, 2019 11:14 pm 
Offline
Off Roader

Joined: Tue Apr 16, 2019 2:03 pm
Posts: 118
Yes I did that but it doesn't work.
How accurate do the timings of the various actions have to be? When it says press accelerator pedal 5 times in 5 seconds does it mean once a second or 5 times in less than 5 seconds?

_________________
Malc

Old enough to know better


Top
 Profile Send private message  
 
 Post subject: Re: ECU reset not working
PostPosted: Tue Oct 15, 2019 7:16 am 
Offline
Extreme Off Roader

Joined: Sun Mar 06, 2016 9:08 pm
Posts: 494
Location: Swindon ,Wiltshire
Car:: Xtrail
Model: T31 Adventurer 2.0dci
Year/Plate: 08
Colour: Iridium Graphite
Mods: Safari lights
crickleymal wrote:
Yes I did that but it doesn't work.
How accurate do the timings of the various actions have to be? When it says press accelerator pedal 5 times in 5 seconds does it mean once a second or 5 times in less than 5 seconds?


5 times in less than 5 seconds................ so just aim for doing all 5 in say 3 seconds


Top
 Profile Send private message  
 
 Post subject: Re: ECU reset not working
PostPosted: Tue Oct 15, 2019 9:48 am 
Offline
Off Roader

Joined: Tue Apr 16, 2019 2:03 pm
Posts: 118
Could it be I have no error codes so that's why it's not flashing?

_________________
Malc

Old enough to know better


Top
 Profile Send private message  
 
 Post subject: Re: ECU reset not working
PostPosted: Tue Oct 15, 2019 1:12 pm 
Offline
Extreme Off Roader

Joined: Sun May 05, 2013 2:27 pm
Posts: 394
Location: Gatineau, Qc, Canada
Car:: Xtrail
Model: Bonavista Edition
Year/Plate: 2006
Colour: Sunlit sand
The procedure to get the codes to flash is very similar. With regard to the timing, you have to be precise. It's best to use a stopwatch to make sure the timing is exact. I think your light is lit up because you have an issue and it will not reprogram and enter idle learning mode until the fault is fixed.


Top
 Profile Send private message  
 
 Post subject: Re: ECU reset not working
PostPosted: Wed Oct 16, 2019 9:34 am 
Offline
Off Roader

Joined: Tue Apr 16, 2019 2:03 pm
Posts: 118
No my light is not lit. I'm trying to do the reset to try to mitigate the annoying rattle which happens when the engine is cold. It could be injectors. It's not the cam chain cos that's been replaced.

_________________
Malc

Old enough to know better


Top
 Profile Send private message  
 
 Post subject: Re: ECU reset not working
PostPosted: Wed Oct 16, 2019 9:51 am 
Offline
Xtrail Nut

Joined: Wed Aug 29, 2018 2:16 pm
Posts: 602
Car:: Xtrail
Model: 2.2 DCi Columbia
Year/Plate: 2006 '06
Colour: Silver
Mods: LED Sidelight bulbs!
Mines the same and getting worse. I'll be changing my SCV soon, so I'm going to see of that helps - could be overfuelling.


Top
 Profile Send private message  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 17 posts ]  Go to page 1, 2  Next

All times are UTC [ DST ]


Who is online

Users browsing this forum: No registered users and 41 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group